Cisco: QoS

From Frotmail Projects
Jump to navigation Jump to search

Situatie

PC1 – R1 – R2 – PC2

PC1 en PC2 zitten met 100 mbit aan de resp. routers. De routers hangen aan elkaar met 10mbit

Ik gooi vanaf PC2 een UDP stream open van 100 mbit naar PC1 terwijl ik een ping open heb: 46 packets transmitted, 2 received, 95% packet loss (76 msec avg)

Logisch, de 10 mbit link houd het niet bij en het is einde oefening voor icmp.

Zet ik nu een service-policy op de interfaces van R2 kom ik een stuk beter uit: 46 packets transmitted, 43 received, 6% packet loss (21 msec avg)

Test config

DC1: nc –4u –l 1234 DC2: dd if=/dev/sda bs=8M | nc -4u 192.168.0.10 1234

R1 (main)

interface FastEthernet0
 description R1-to-R2
 ip address 192.168.2.1 255.255.255.252
 duplex auto
 speed 10
!
interface FastEthernet1
 switchport access vlan 5
!
interface Vlan5
 description PC1
 ip address 192.168.0.1 255.255.255.0
!
ip route 192.168.1.0 255.255.255.0 192.168.2.2

R2 (office)

class-map match-all high
 match  precedence 4
class-map match-all tag-high
 match access-group name acl-high
!
policy-map prio
 class high
   priority percent 50
policy-map tag
class tag-high
  set precedence 4
!
interface FastEthernet0
 description R1-to-R2
 ip address 192.168.2.2 255.255.255.252
 duplex auto
 speed 10
 service-policy output prio
!
interface FastEthernet1
 switchport access vlan 5
!
interface Vlan5
 ip address 192.168.1.1 255.255.255.0
 service-policy input tag
!
ip route 192.168.0.0 255.255.255.0 192.168.2.1
!
ip access-list extended acl-high
 permit icmp any any
!